Official announcements for AstroFlux
#65497 by Tef Wed Nov 16, 2016 9:20 am
Hey all,

I just wanted to say we are looking into it and we have been for a while. Though we can't really say why this is happening for some players. I've been talking with our host and service provider (PlayerIO) and they can't see any anything odd or weird thing happening on our server. Personally I've gotten a disconnect once or twice in the last year. So it's very hard for us to debug since its working fine for us.

Background to Problem
Most disconnects happen after the server has too many outstanding packages to the client, ie. the client is not answering. So in one way or another the connection to PlayerIO's servers are broken or unstable. The most common way to reproduce this is to use a wireless network with low strength, say a 3G/4G mobile connection with poor reception. Or by other programs hogging the network line. Like a download, video or other big data streams like a backup.

The other thing that can happen is that the connection went through but was force closed by the client. This can happen if your internet service provider, computer, firewall, router or other machinery or program didn't like the connection and forced a disconnect.

Another cause of this problem can be that the server has crashed or is too busy to respond, that usually disconnects everyone from the same room.

What we are doing
We have contact with PlayerIO about this and is trying to solve the issue with their help. However, the best answer they have given us is that it is because players have a poor internet connection. But we don't really believe that so we are trying to find another cause. But its really hard to debug and doesn't seem to happen for everyone. We will work on this but in the meantime check the possible solutions below.

Possible Solutions
- Check your browser tabs for ads. They consume a lot of CPU and can conflict with the Astroflux flash.
- Turn off any excess browser tabs that might be in conflict with Astroflux.
- Turn off any torrent, backup or programs using high bandwidth.
- Make sure the flash version is updated to the latest version.
- If you play through a browser, try switch browser and check for any conflicting plugins, scripts.
- Check the current status of PlayerIO, https://playerio.com/status/
- Check if your wireless connection is poor, if its dropping packages.
- Check if your wireless router/hub/switch is of poor quality.

More on lag issues can be found here:
viewtopic.php?f=20&t=2789
#65502 by traf Wed Nov 16, 2016 9:44 am
very good information! we look forward to what you guys have planned!

Please feel free to private message me!

"Do not rebuke mockers or they will hate you; rebuke the wise and they will love you."

“Don't write so that you can be understood, write so that you can't be misunderstood.”
― William Howard Taft
#65505 by Bellatrix Wed Nov 16, 2016 10:06 am
Great, thx for sharing.

I think that many of the players that have issues now did not have issues before, so if they could post around what time they started to have issues maybe it will be easier to track down if the error is some where else.

Bellatrix, the shining star of Astroflux
#65511 by DaGGerz Wed Nov 16, 2016 11:54 am
I don't think it's a client/user issue when everyone is disconnected at the same time.
Stay in Fulzar for 2 hours and when you get disconnected, check the chat and you'll see many people disconnecting at the same time.

#65512 by Tef Wed Nov 16, 2016 11:59 am
DaGGerz wrote:I don't think it's a client/user issue when everyone is disconnected at the same time.
Stay in Fulzar for 2 hours and when you get disconnected, check the chat and you'll see many people disconnecting at the same time.


Yes, the mass disconnects are probably our fault, as the room has failed in some way. Please look out for causes. We had similar things going on before in Fulzar when enemies started attacking each other and the room became unplayable.
#65518 by Hyperion Wed Nov 16, 2016 1:08 pm
I have a hunch those Nexar Bombers are playing a big part in this given how my fps drops in chunks each time a bomb goes off (about 15 fps from 60 in Fulzar, about 20-30 fps from 60 in Vorsran).
#65524 by TheCen Wed Nov 16, 2016 2:31 pm
Tef wrote:
DaGGerz wrote:I don't think it's a client/user issue when everyone is disconnected at the same time.
Stay in Fulzar for 2 hours and when you get disconnected, check the chat and you'll see many people disconnecting at the same time.


Yes, the mass disconnects are probably our fault, as the room has failed in some way. Please look out for causes. We had similar things going on before in Fulzar when enemies started attacking each other and the room became unplayable.


It's not just the room. I've been on a few times recently and the whole game crashed. Everyone across the whole game was disconnected.

WARNING:
DON'T TRUST ANY MODERATOR. THEY DELETE YOUR COMMENTS. MODERATORS IN GENERAL HAVE RUINED THE GAME PLAY OF MANY INDIVIDUALS. AND THEY JUST KEEP DOING IT. NO REGARDS FOR RESPECT.
#65525 by Tef Wed Nov 16, 2016 2:43 pm
TheCen wrote:
Tef wrote:
DaGGerz wrote:I don't think it's a client/user issue when everyone is disconnected at the same time.
Stay in Fulzar for 2 hours and when you get disconnected, check the chat and you'll see many people disconnecting at the same time.


Yes, the mass disconnects are probably our fault, as the room has failed in some way. Please look out for causes. We had similar things going on before in Fulzar when enemies started attacking each other and the room became unplayable.


It's not just the room. I've been on a few times recently and the whole game crashed. Everyone across the whole game was disconnected.


Yes, that can happen, but that would be very noticeable even for us. Then its almost 100% sure that PlayerIO has gone down. Which are not the kind of disconnects I'm talking about here.
#65529 by DevNull Wed Nov 16, 2016 4:33 pm
Firmware update on router ..check

flash up to date...check

Traceroute are clean no bad hops...check

Internet connection...FiberOptic check and is fast


as soon as I warp to Fulzar BAM disconnect than happens about 10 more times..


Im hardlined to router so no wireless issues.

I dont have many friends, I just know alot of people
#65530 by Peter2 Wed Nov 16, 2016 4:41 pm
what is the domain name of the server hosting AS on kongregate ?

u can aslo make a batch file .bat and put in it:
ping -t google.com
to check your global connection latency
mine is 63mn while it is 20ms higher on astroflux.net and playerio.com is 215-220ms

i ve got some issue when latency reach 105-110 ms (in game, activating system chat)..specially with blob when timing is crucial for my config ( cloak, hs..i am running a shadow)

mobile sync (ios or android) use to get priority on your local lan as they start sync when a wifi is accessible by default, check them too.
I use to lag very hard on this game, free tp or hs not working...and i use to disable every stuff which can make the lag worth (all auto update stuff, services, program,task scheduler, got bandwith meter too)

most people confuse speed and latency, this game consume like 10-15KB/sec, which is nothing..but latency from server/client is the Achilles heel
#65533 by DevNull Wed Nov 16, 2016 6:59 pm
8 disconnects in a row after warping to Fulzar...


Awesome.

I dont have many friends, I just know alot of people
#65534 by Tef Wed Nov 16, 2016 7:16 pm
TheVox wrote:8 disconnects in a row after warping to Fulzar...


Awesome.


Which client are you using, astroflux.net, steam, Kongregate, armorgames, FB, standalone?
#65536 by DevNull Wed Nov 16, 2016 7:27 pm
Tef wrote:
TheVox wrote:8 disconnects in a row after warping to Fulzar...


Awesome.


Which client are you using, astroflux.net, steam, Kongregate, armorgames, FB, standalone?



AF.net connecting via facebook..


Checked everything nothing has changed as far as I can tell just started happening after this last update

I dont have many friends, I just know alot of people
#65540 by Tef Wed Nov 16, 2016 9:04 pm
TheVox wrote:
Tef wrote:
TheVox wrote:8 disconnects in a row after warping to Fulzar...


Awesome.


Which client are you using, astroflux.net, steam, Kongregate, armorgames, FB, standalone?



AF.net connecting via facebook..


Checked everything nothing has changed as far as I can tell just started happening after this last update


As in the New Missions + Changed Drops update?

That update was only a content update, so either the problem existed earlier or its not probably related.
#65541 by TheKrazyKangaroo Wed Nov 16, 2016 9:12 pm
I'm getting at least 3 disconnects a day whilst playing and none of them affect me only. Sometimes when the game is loading, it disconnects me again and again until I just refresh the page. Could you also try to fix the broken warp from pvp, every time you warp out of pvp, you have to refresh the page to return to the game which I could see could be really annoying to Steam players. (Armor Games player).

Who is online

Users browsing this forum: No registered users and 3 guests

About

Welcome to the AstroFlux forum! This forum is here to provide you with a friendly environment where you can ask questions and receive helpful information from experienced players. Please Join the discussions in the Astroflux forums. The game developers are active here and are happy to hear what you think!

AstroFlux is a MMO space shooter with numerous weapons, upgrades and abilities. Explore the galaxy and collect space junk to gain resources for new technologies.